It is currently Tue Oct 26, 2021 8:59 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jun 20, 2021 4:24 pm 
Offline
SLE Member
SLE Member

Joined: Fri Oct 01, 2010 3:08 am
Posts: 27
Location: Redmond, OR
Year and Trim: 89 Pontiac Bonneville SSE
Situation: Replaced rear wheel cylinders both sides. Did not disassemble ANYTHING else - brake shoes (80 to 90% thickness), springs, anything. Brakes worked perfectly going in except for leakage on LR cyl and starting to seep on RR cyl. Was able to R&R cyls without undoing anything else. Bled the lines in the normal fashion (in the distant past I was ASE certified in several categories so I am familiar with most aspects of car service). Drive test was definitely unsat. Inspection revealed no rear brake application. Could turn the drums by hand with brake pedal applied. Then I went to my (factory) shop manual and I finally found where it describes a specific procedure to bleed the rear brakes using the accumulator pump. So I went through that drill and a test drive was better, but not much. When the brake and ABS lights are off, applying the brake gets immediate slowing (and both lights come on), but strong braking comes only after 1 second or so and the pedal rises at the same time.
Question is - what am I overlooking or leaving out? I'm going to bleed them again, paying EXACT attention to the procedure and run a full quart of fluid (this is getting expensive) through it. I'll report results.

_________________
'89 Bonneville SSE daily driver (prior 3800 was '90 Buick LeSabre - solid car)
'06 Suburban 5.3 280,000 miles
'67 Corvette Coupe 427/435, 1 owner (motor in storage, now running with 4 bolt 327)
'38 Chev Business Coupe, all original (wife won't let me "improve" it).
'80 BMW R100 Frankenscooter from a basket case.


Top
 Profile  
 
PostPosted: Tue Jul 13, 2021 7:41 pm 
Offline
SLE Member
SLE Member

Joined: Fri Oct 01, 2010 3:08 am
Posts: 27
Location: Redmond, OR
Year and Trim: 89 Pontiac Bonneville SSE
Follow up and enlightenment. After spending lots of time reading other car forums all relating to Teves 2 ABS systems (many other brands used them during late '80s and early '90s), I found one particular post describing exactly my symptoms which pointed to the accumulator. The post was from the North American Turbo Coupe Organization > Tech Garage > Tech Articles > Troubleshooting the Teves II electro-hydraulic braking system.

Searching for the part results in MANY choices which "might" fit ranging in price from about $75 to $600. They are listed for Jaguar, Range Rover, Mercedes, Buick, Mitsubishi and many others. They all perform the same function but differ in size a little. Based on what I read regarding "seems to fit", I chose one made by Bosch for a Mercedes. It's a little smaller, but the thread fits and seals and now it works normally. The lights cycle as they should and the pedal feels right. Cost was (new, not used) $82 from a seller on ebay. The alternative was to go to a shop where the whole assy which includes master cyl, reservoir, valve block, pump and accumulator is all that is available through NAPA or ORielys for $1500 plus labor. I talked to several mechanics and none of them had even heard of the Teves system. Hardest part to R&R was to get a wrench on it. Oil filter wrench fit, but no room to turn it. BIG channel locks worked. Hope this helps someone.

_________________
'89 Bonneville SSE daily driver (prior 3800 was '90 Buick LeSabre - solid car)
'06 Suburban 5.3 280,000 miles
'67 Corvette Coupe 427/435, 1 owner (motor in storage, now running with 4 bolt 327)
'38 Chev Business Coupe, all original (wife won't let me "improve" it).
'80 BMW R100 Frankenscooter from a basket case.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Crunchy Brake pedal (teves)

phoenix_flame220

5

1957

Wed May 16, 2012 4:58 pm

phoenix_flame220 View the latest post

There are no new unread posts for this topic. 89 SSE Teves ABS CHANGE OVER

yogidad

15

2584

Sat Apr 11, 2015 1:28 pm

yogidad View the latest post

There are no new unread posts for this topic. Teves Master Cylinder Conversion

limabee

7

4900

Wed Apr 25, 2012 10:29 am

MattStrike View the latest post

There are no new unread posts for this topic. 1990 - Can't get rear brake drum off?

missin44

4

1955

Wed Apr 13, 2011 8:07 pm

myfirstbonnie View the latest post

There are no new unread posts for this topic. Weak electrical system?

Asymetric

8

1439

Thu Nov 11, 2010 11:32 pm

shortstuf212559 View the latest post

 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO