PontiacBonnevilleClub.com
http://www.pontiacbonnevilleclub.com/forum/

Dead 03 SSEI
http://www.pontiacbonnevilleclub.com/forum/2000-2005-other-than-gxp/topic51492.html
Page 1 of 1

Author:  Brybry [ Sun Feb 11, 2018 4:30 pm ]
Post subject:  Dead 03 SSEI

First the car: 2003 Bonneville SSei. Sunroof, power everything, but no factory XM radio. Everything on the car is factory, no aftermarket upgrades except for the brakes.

After a heavy rainstorm last night, I went out to drive to work and my Bonnie wouldn't start. The security light flashes, the door chime works, the remote lock and unlock works, but I have zero dash movement, no radio, no AC, no DIC, no windows/sunroof movement, and no starting. I have replaced the battery, and checked grounds, but with no luck. I have tried the trick of key in and on for 15 minutes, followed by shutting off for 10 seconds and then starting up, but same thing.

I know I had water intrusion because the floor board was wet on both the driver and passenger front floor board. I suspect that one of the computers went, but which one? I don't want to go randomly replacing computers because that will get really expensive really fast.

Any ideas anyone?

Author:  RJolly87 [ Sun Feb 11, 2018 10:01 pm ]
Post subject:  Re: Dead 03 SSEI

I would check to make sure you have power and grounds in the area of the known water intrusion.

What you are describing could very well be coincidence, and you simply had an ignition switch cut loose on you.

Check the basics before thinking the worst.

Author:  RJolly87 [ Sun Feb 11, 2018 10:03 pm ]
Post subject:  Re: Dead 03 SSEI

To clarify, I would trace it out with a test light to see where you are losing power. With that many systems out, it's probably very big and very apparent

Author:  Brybry [ Mon Feb 12, 2018 1:48 am ]
Post subject:  Re: Dead 03 SSEI

I pulled the carpet and checked the grounds. All are good. I can set the radio time, so I know power is getting to there and the ground for the radio is good at least. I replaced the battery mainly because it was 10 years old. The new battery is fully charged as well.

Hooking up a scanner to the OBD2 port just shows error, but the port gets power because the scanner lights up.

Author:  Brybry [ Tue Feb 13, 2018 5:48 pm ]
Post subject:  Re: Dead 03 SSEI

UPDATE: I have replaced the ignition switch with no change. my hazards work, if it hit the buttons for the DIC, I get my trip and mileage to show. I can set the radio and have it save the time. However it is like I am not even inserting the key at all.

I am really at a loss here and just about ready to call a wrecker to come and take this car away.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/