It is currently Sat Jan 16, 2021 10:35 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Wed Nov 19, 2014 1:03 am 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
Hey all, I know that this a recurring problem for lots of GXP owners and there may be a thread about this somewhere, but I am new and having trouble searching for discussions on specific things. Having said that, I'll get to the point.

The spedometer will randomly continue to climb with my speed until it eventuallt maxes out past 160mph, it seems that the only reliable way to reset it is to pull the entire cluster off of it's electronic connections, then push it back in. Sometimes it will reset itself back to 0mph when I shut the car off and turn it back on though. I have not been able to figure out what certain thing or things cause this speedometer issue, so at this point it seems like it is a random problem. I have seen that this problem may be stepper motors, but I am not completely sure about that.

The second issue is that my system will periodically switch to metric. The temperature, speed, and all other units of measurement will turn to metric. The E/M button on my DIC does not work, along with the reset button. Mode and select are the only buttons that work. This also resets itself by either pulling the instrument cluster out and putting it back in, or it will eventually make it's way back to standard units with a few on/off cycles of the car.

If anyone has any experience or has heard anything about these issues, any and all input would be greatly appreciated.


Top
 Profile  
 
PostPosted: Wed Nov 19, 2014 9:19 am 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Mon May 10, 2010 6:11 pm
Posts: 9263
Location: Chicago, IL
Year and Trim: 2003 SLE
PM our resident parts guy, Andrew (Harofreak00). He can send you a new GXP cluster that will have new motors which will fix the issue, or you can send him yours and he will repair it for you.

As for the DIC, that sounds like the button is broke and I would assume the whole DIC needs replacement. Again, something to ask Andrew about.

_________________
-Car Guy Carl
"Penelope" - 2003 SLE - 215k Miles
"Sydney" - 2000 Honda S2000 - 81k miles
Image


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 3:31 am 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
Awesome, thank you NOS. I will hit him up tomorrow.


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 10:39 am 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Mon May 10, 2010 6:11 pm
Posts: 9263
Location: Chicago, IL
Year and Trim: 2003 SLE
I noticed you're in MN, he is also in MN. Might consider looking how close he is to you to forego shipping costs and troubles.

_________________
-Car Guy Carl
"Penelope" - 2003 SLE - 215k Miles
"Sydney" - 2000 Honda S2000 - 81k miles
Image


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 11:50 am 
Offline
Retired Site Developer
Retired Site Developer
User avatar

Joined: Tue May 27, 2008 10:30 pm
Posts: 20960
Location: MN/IA
Year and Trim: '17 Silverado 1500
He's kind of a hike, 3-ish hours from him. Not necessarily not worth it, but shipping that stuff is cheap enough....

_________________
Bye Bye:
Image
RIP sandrock
Sirius wrote:
Think about it. You’re tooling down the road in your Prius, knowing full-well that this thing being green is as big a sham as federally mandated ethanol-enriched gas, Russia pulling out of Ukraine, and Obamacare.


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 2:05 pm 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
It's always good to have options!


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 2:17 pm 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Wed May 13, 2009 10:45 pm
Posts: 5707
Location: CHICAGO
Year and Trim: 2006 STS-V, 2004 GTO, 2009 G8 GT
Just as a point of parlimentary procedure, our DIC's in these cars just seem to be tempermental to begin with and replacing it with another doesn't mean it won't act up.

My DIC always had issues maintaining it's geographic north (or whatever you want to call it), when it was <32* out and constantly requiring "Recalibration". Meaning if I wanted to know what direction I was going, I needed to drive around in circles 3 - 4 times, one way, then 1 circle the other direction to get it to recalibrate (or whatever the procedure is). Only for it to need it to be done again the next day.

>32* it was fine...

_________________
Image

Retired Bonneville Owner and former GM Tech:
2004 Pontiac Bonneville GXP: Black/Ebony *SOLD*

Summer Toys: Combined 827 RWHP / 877lb/ft RWTQ
2004 Pontiac GTO: Impulse Blue Metallic/Black/M6: lots 'o mods, 415 RWHP / 405lb/ft RWTQ!
2006 Cadillac STS-V: Light Platinum Metallic/Light Gray/A6 - Spectre CAI, Magnaflow exhaust, Speed Inc. tune, 412 RWHP / 472lb/ft RWTQ

Daily Drivers:
2015 Chrysler Town & Country Limited Platinum: Mommy's NEW RGC
2007 Chrysler Town & Country Limited: Daddy's beater affectionately called the Rolling Garbage Can or "RGC" for short
2009 Pontiac G8 GT: L76, Sport Red Metallic
2009 Chevrolet Impala SS: LS4 V8, Victory Red
2003 Chevrolet Suburban 2500: Doeskin Tan - new plow truck
1999 Chevrolet Suburban: Sunset Gold Metallic - Daddy's winter beater and plow truck


Top
 Profile  
 
PostPosted: Thu Nov 20, 2014 7:30 pm 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
I have noticed the compass losing calibration too MXR57, although I have gotten lucky because it has only happened twice in the last 2 months. It usually ends up fixing itself after a few times of the entire car being shut down and started back up again. I really wish there were fixes for certain things like this. As with you, I have noticed it happening when it is cold out as well. I'm just hoping that by switching the DIC buttons out, I will be able to switch it back to standard when it decides to switch to metric. I suppose I could go and find the wiring schematic for this type of vehicle and try to jump the wires. If I am successful with jumping the wires then I would comfortably be able to switch to a new DIC. If nothing happens, then I might as well just try to live with the problem....ugh :-( It would just be really nice to have the buttons work so that I'll be able to change some of the options that allow to personalize the vehicle, at this point I can only view them and go to the next option.


Top
 Profile  
 
PostPosted: Fri Nov 21, 2014 5:44 pm 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
Found out why my some of my buttons on the DIC weren't working. I went to the junkyard and bought a whole new control panel that was off an SSEI ($45.00). I plugged it in and it worked, but it was the wrong color. It was easy enough to swap out the new chip into my old set up. Once I opened up the old control panel, it was apparent why there was a malfunction.

This is the old one.
http://s1370.photobucket.com/user/wadeh ... sort=3&o=1

This is the new one.
http://s1370.photobucket.com/user/wadeh ... sort=3&o=0

Everything on the DIC works the way it should now. Next step, talk to Bonnevilles Unlimited and get my stepper motors and backlights on the instrument panel replaced. :-)


Top
 Profile  
 
PostPosted: Fri Nov 21, 2014 5:49 pm 
Offline
SLE Member
SLE Member

Joined: Tue Nov 18, 2014 6:13 pm
Posts: 25
Location: Pipestone, Minnesota
Year and Trim: 2005 GXP
I forgot to mention that all the lights work now too :-)

http://s1370.photobucket.com/user/wadeh ... sort=3&o=0


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Instrument cluster removal

CosmicVagabond

1

1954

Sun Dec 16, 2012 10:46 pm

harofreak00 View the latest post

There are no new unread posts for this topic. Instrument Cluster Removal

[ Go to pageGo to page: 1, 2 ]

Bigerik

22

14704

Tue Aug 01, 2017 11:10 am

Euell View the latest post

There are no new unread posts for this topic. Gremlins in my cluster.....

Bl4z3

10

1745

Thu Jan 31, 2013 1:54 am

repinS View the latest post

There are no new unread posts for this topic. 2005 GXP Cluster Gone Wild

erichthecatt

1

1386

Fri Sep 06, 2013 10:54 am

harofreak00 View the latest post

 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO