It is currently Sun Feb 18, 2018 9:53 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Feb 25, 2017 2:52 am 
Offline
LE Member

Joined: Sat Feb 25, 2017 2:27 am
Posts: 1
Year and Trim: 1993
First off, I've been viewing this forum for a few years now and want to mention how helpful it has been for all my troubleshooting and repair needs. Thank you to everyone with all the help and incredible knowledge!!

Unfortunately, I'm stuck and have searched high and low for an answer to the following questions: my oxygen sensor harnesses melted, leaving me the wonderful task of identifying the functions of the wires from the harness to the sensor harness...the 3 wires are black, purple and what appears to be orange/black coming in and I purchased a 4 wire Denso sensor with 2 black wires, a white and a blue. As I mentioned before, the harness is melted...my questions are pretty simple...can I make this work by hard wiring and which wires go where? I'm at a complete stand still right now and might be slightly frustrated...lol

Thank you in advance for any and all info! She's on her last leg and I am determined to bring her back to life!!!


Top
 Profile  
 
PostPosted: Sat Feb 25, 2017 12:40 pm 
Online
Administrator
Administrator
User avatar

Joined: Mon May 19, 2008 7:01 pm
Posts: 16655
Location: Central Illinois
Year and Trim: 1992 SSE
2009 G8 GT
I don't know if you can make a 4 wire sensor work in a 3 wire setup. My best advice is to get the right sensor and either hard wire it in by matching wire colors or to also get a new harness connector pigtail and wire that in.

_________________
Image
WHITE WHINE - IT'S INTOXICATING. 1992 SSE Supercharged 236.26 ci (.040 Over)
15.090 at 90.2 MPH on old engine w/ slipping trans & melted O2 sensor - Gen 3 M62 and matching TB, Gen 2 Pully, Zillamotorsports Ported LIM, YT 1.72 Roller Rockers, SII FPR & Injectors, Easy Performance Gen 3 Air/Fuel Calibrator, Hypertech Thermomaster chip w/ 160 Thermo, TransGo Shift Kit, Infinity/Pioneer Speakers and 10" Subs, 1300 watts, 140 amp Alternator, Ricepipe CAI w/ heatshield, Pilot Angel Eye Foglights, Clear Corners, '02 17" Chrome Bent 5's, Magnaflow F-Body Muffler and Hi-flo Cat, McCoy Motorsports Ceramic Coated Ported Exhaust Manifolds, Fan Override, PowerSlot Slotted Rotors.
2009 G8 GT - Sport Red Metallic, loaded, SOLO Axlebacks, Rotofab Intake, Tuned, autodim Trailblazer mirror, removed intake manifold cover, HSV GTS triple gauge pod, two tone red-hot shifter and HSV SuperSport steering wheel, GXP rear sway bar and diffuser


Top
 Profile  
 
PostPosted: Sun Feb 26, 2017 2:24 pm 
Offline
Posts like an L67
Posts like an L67

Joined: Thu May 01, 2014 9:37 pm
Posts: 1224
Year and Trim: 1993 SLE
1998 SE
2001 SSEI
2002 SSEI
J Wikoff wrote:
I don't know if you can make a 4 wire sensor work in a 3 wire setup. My best advice is to get the right sensor and either hard wire it in by matching wire colors or to also get a new harness connector pigtail and wire that in.


x2
Trying to adapt a part that doesn't belong in the car is going to lead to nothing more than frustration.

The best solution is to buy the Denso 2343011 or ACDelco OE sensor AFS76 http://www.rockauto.com/en/catalog/pontiac,1993,bonneville,3.8l+v6,1247419,exhaust+&+emission,oxygen+(o2)+sensor,5132
and the ACDelco replacement pigtail PT420 (the connector that mates to the sensor connector) http://www.rockauto.com/en/catalog/pontiac,1993,bonneville,3.8l+v6,1247419,electrical-connector,oxygen+(o2)+sensor+connector,2604
to make the task easier and the car run better.

Rockauto typically has good prices and they give forum members a discount on parts.
vendor-s-forum/topic49991.html

You'll find that Denso and ACDelco sensors perform best in our cars:
care-and-feeding/topic40156.html

I would also be sure to check the ground buses (wrapped in electrical tape) that are beneath the carpet on both the driver and passenger sides floor near the kickpanels.
These grounds often corrode and lead to various serious electrical issues.
This thread has pictures of the buses http://pontiacbonnevilleclub.com/forum/viewtopic.php?f=19&t=30286


Top
 Profile  
 
PostPosted: Sun Feb 26, 2017 4:18 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Fri Jun 24, 2016 12:15 am
Posts: 493
Location: Isanti, MN
Year and Trim: 2000 SLE Saved from the scrapyard.
actually, more importantly is that even if you wire it correctly, it may end up not working properly once it comes on line. I had switch computers in my 98 Astro to a 2000 PCM with a custom tune and once I got it wired in and running, it died as soon as the O2 sensors came online. I ended up having to get a set that matched the computer because the original sensors were not compatible.

_________________
A temporary fix does not exist. It becomes a solution until it needs to be fixed again.
Image
https://photos.google.com/album/AF1QipOYkkevV0gKTHc_8Cstuy8yS1Qyx6SiIKeTzuHy


Top
 Profile  
 
PostPosted: Mon Feb 27, 2017 5:31 pm 
Offline
Retired Admin/Techinfo Admin
Retired Admin/Techinfo Admin

Joined: Mon May 19, 2008 2:08 pm
Posts: 26000
Location: Space Coast, or at least it used to be
Year and Trim: 03 SLE, 95 SE, 95 TS SE
The 93 is kind of a one off year in that it uses a 3 wire heated O2 sensor.. First year of the heated O2 with the 3800..

1994-96 used the AFS-75 4 wire heated..

Try to get a 3 wire for the 93... AC Delco AFS-76 is recommended.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. 99 lesabre oxygen sensor wiring problems

trf_ssei

2

785

Tue Jan 15, 2013 8:38 pm

trf_ssei View the latest post

There are no new unread posts for this topic. p0134 insufficent activity bank 1 sensor 1 oxygen sensor

boostinta

15

4328

Thu Jun 04, 2009 12:50 pm

boostinta View the latest post

There are no new unread posts for this topic. Oxygen sensor

ColdScrip

4

876

Mon Jun 23, 2008 12:51 pm

lash View the latest post

There are no new unread posts for this topic. Which oxygen sensor is it?

ohenry5

4

790

Wed Dec 01, 2010 11:24 pm

LeSabre in Buffalo View the latest post

There are no new unread posts for this topic. Oxygen Sensor

3800SERIESII

12

1657

Sun Aug 12, 2012 4:06 pm

01bonneSC View the latest post

 


Who is online

Users browsing this forum: Majestic-12 [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO