It is currently Sun May 19, 2024 4:02 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: front end shock issue??
PostPosted: Thu Sep 04, 2008 9:56 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Thu May 22, 2008 6:50 am
Posts: 598
Location: Langhorne, Pa
Year and Trim: 2007 Impala SS
1997 LeSabre Limited
Hi,

Its been ages since i drove my sisters leSabre. well the other day i got in and drove it, went over a small pot hole and a sound, a new sound came from the front end.

The best way to describe it; if you take a thin cookie tray and wave it around, it makes that "whopping" sound... thats the sound this car makes over every freakin bump or pot hole. Both sides of the car and in the front only.
Im wondering with 115,000 miles on her now if the shocks are due for a replacement.??

thanks for any advice.

_________________
Image

2007 Impala SS - 30k 5.3L V8
1997 LeSabre Limited - 115k
Gone but never forgotten:
2001 Bonneville SE
1992 Bonneville SE


Top
 Profile  
 
PostPosted: Wed Sep 10, 2008 4:09 pm 
Offline
Posts like an L27
Posts like an L27
User avatar

Joined: Thu May 29, 2008 2:19 pm
Posts: 691
Location: Pleasant Prairie, WI
Year and Trim: .
Have they ever been replaced?


Top
 Profile  
 
PostPosted: Wed Sep 10, 2008 8:02 pm 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Thu May 22, 2008 6:50 am
Posts: 598
Location: Langhorne, Pa
Year and Trim: 2007 Impala SS
1997 LeSabre Limited
never been replaced. Im throwing a set on the Bonneville next week she's overdue, im gonna throw a new set on the Buick too while i am at it. We'll see if thats the issue.
Thanks for the reply. :wink:

_________________
Image

2007 Impala SS - 30k 5.3L V8
1997 LeSabre Limited - 115k
Gone but never forgotten:
2001 Bonneville SE
1992 Bonneville SE


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. EGR Issue!

philipk65

3

1883

Mon Feb 01, 2010 11:01 am

J Wikoff View the latest post

There are no new unread posts for this topic. 00 gp gtp axle issue

its840

1

1933

Tue Mar 06, 2012 9:48 pm

harofreak00 View the latest post

There are no new unread posts for this topic. pcm issue thrasher shift kit

mixedgasrider

2

2218

Tue Dec 28, 2010 11:34 pm

00Beast View the latest post

There are no new unread posts for this topic. 4T65E TCC lock-up issue

1fatcat

12

18165

Sat Jul 25, 2009 11:29 pm

1fatcat View the latest post

There are no new unread posts for this topic. A/C issue. 2003 Buick LaSabre

Oldman

1

1971

Sun Aug 07, 2011 11:05 am

imidazol97 View the latest post

 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO