It is currently Mon Sep 24, 2018 3:00 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Oct 27, 2013 12:04 am 
Offline
Posts like an LN3
Posts like an LN3

Joined: Thu Nov 04, 2010 9:42 pm
Posts: 559
Location: Northern MN
Year and Trim: 5x former 3800 Buick/Olds owner
Just picked up a nice 1998 Regal LS, but what I thought was a bad blower motor resistor may have more to it....

Has manual dual climate control, but only works on low and high. Half of the time it doesn't work at all, and only at full hot temperature. Changing the airflow/mode works fine though. Cruise control will also not work - I have gotten the cruise light to come on for a split second though. BUT....odometer is dim like the headlights are on.

Upon hitting the trip odo or finagling with the climate control, the odo will light up to full strength, then revert once I turn the fan off. When it does this, I can hear the faint click from the headlight switch like when you turn the headlights on. It will do this repeatedly as I switch the fan on and off. At night time, it has auto headlights, but sometimes they don't work....if the fan kicks in like it should, the headlights also come on, but if the fan decides not to work, I have to manually turn them on. If the fan is working, I can make the auto headlights turn on and off by simply turning the fan on and off.

While driving it tonight, I turned the high beams on, and they were hesitant to engage, then upon getting them to work, all exterior lights went black, until I turned the highbeams off. It may have coincided with the fan kicking on or off, as I was experimenting with it at the time. DIC also does not work, and the fog lamps do not work - buttons to both are all non-responsive.

Upon reading online, it seems a common issue is ignition switches that have all these accessories tied in together.....does this seem right? So far, it's starting and running great, no cutting out or unusual things happening with the key or ignition itself. All backlighting works perfectly inside, steering wheel controls for audio work perfectly, gauges all work perfectly, radio works perfect, wipers work perfect. Check engine light is on (maybe unrelated, but it runs and drives great, gets 30MPG) and change oil light comes on for the first minute or two after startup. So.....any thoughts?

_________________
~Ben

Image
2010 Chrysler 300 Touring Signature Series, Cool Vanilla - chrome 18's, MyGig touchsreen, all the toys.
2004 Chevy Avalanche LT 4x4, WBH, Arrival Blue Metallic - CAI, MBRP cat-back exhaust, lots of mods and all the options.
2004 Ford Mustang Premium convertible, Screaming Yellow - 18" staggered Bullitt wheels, 1.5" drop Eibach springs, CAI.
1973 Cadillac Fleetwood Series 60 Brougham, Antigua Blue - 23 ft, 5200 lbs, and 472 cubes of luxo-barge goodness.
1998 Chevy Corvette convertible, Light Carmine Red Metallic


Top
 Profile  
 
PostPosted: Sat Jan 11, 2014 11:29 pm 
Offline
Posts like an LN3
Posts like an LN3

Joined: Thu Nov 04, 2010 9:42 pm
Posts: 559
Location: Northern MN
Year and Trim: 5x former 3800 Buick/Olds owner
Just a follow-up, the issue got resolved not long after the original post, it ended up being an ignition switch.

_________________
~Ben

Image
2010 Chrysler 300 Touring Signature Series, Cool Vanilla - chrome 18's, MyGig touchsreen, all the toys.
2004 Chevy Avalanche LT 4x4, WBH, Arrival Blue Metallic - CAI, MBRP cat-back exhaust, lots of mods and all the options.
2004 Ford Mustang Premium convertible, Screaming Yellow - 18" staggered Bullitt wheels, 1.5" drop Eibach springs, CAI.
1973 Cadillac Fleetwood Series 60 Brougham, Antigua Blue - 23 ft, 5200 lbs, and 472 cubes of luxo-barge goodness.
1998 Chevy Corvette convertible, Light Carmine Red Metallic


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. 1998 Regal 3.8 P0401 & P0171

Hotwheels

4

1730

Fri Feb 14, 2014 1:03 am

Hotwheels View the latest post

There are no new unread posts for this topic. 02 regal console

deano55

2

593

Fri Dec 16, 2016 9:22 pm

deano55 View the latest post

There are no new unread posts for this topic. 99' Regal GS Headlights Don't Work

Slayer636

5

3562

Tue Apr 26, 2011 7:14 am

lukee1982 View the latest post

There are no new unread posts for this topic. 2002 Buick Regal

deano55

2

1084

Sat Mar 03, 2012 6:12 pm

deano55 View the latest post

There are no new unread posts for this topic. 1999 Regal P1860

BoiseGTP

1

972

Mon Apr 07, 2014 8:42 pm

BillBoost37 View the latest post

 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO