It is currently Sun Aug 19, 2018 9:48 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Cooling system problems
PostPosted: Tue Aug 07, 2018 10:54 am 
Offline
LE Member

Joined: Tue Aug 07, 2018 8:59 am
Posts: 2
Year and Trim: 1997 SE 3.8L
Hello everyone, I need some help with a problem I am having with my cooling system in my 1997 Bonneville SE w/a 3.8L non supercharged engine. The car sat for about 8 months because it took me that long to find somewhere to buy a set of pre-bent stainless steel brake lines, anyway, after installing the brake lines the car ran fine for about 2 months and then the problems began. First I had to replace the battery. Then the alternator quit. And now the cooling system trouble. 1st the temp gauge began fluctuating, high (220 deg.) and then back to about 180. Somehow that problem seemed to correct itself but started again in about 1 month. I have none of the tell tale signs of gasket problems, no water in oil, no oil in water, no visible leaks, and the car runs great but 2 times it built up pressure in the radiator bad enough to blow coolant out of the upper rad hose. I replaced the tstat and the cap, my temp holds steady at 195, no white smoke from the exhaust. Then the 2nd high pressure problem. Does anyone think if I replace the water pump, radiator, put aluminum hoses in the tensioner, and new upper and lower rad hoses this may solve this problem. Also, my cooling fans are working and I never had my temp over 220 deg, so I never overheated the engine. Thanks in advance for any help, Bill


Top
 Profile  
 
PostPosted: Wed Aug 08, 2018 11:45 am 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Wed May 13, 2009 10:45 pm
Posts: 5483
Location: CHICAGO
Year and Trim: 2006 Cadillac STS-V, 2004 Pontiac GTO
Probably just a flaky ECT sending unit or the stepper motor in the gauge if the car isn't actually physically overheating. 195* is right where it should be with a stock t-stat.

My inclination is the ECT sending unit being the culprit.

_________________
Image

Retired Bonneville Owner and former GM Tech:
2004 Pontiac Bonneville GXP: Black/Ebony *SOLD*

Summer Toys: Combined 827 RWHP / 877lb/ft RWTQ
2004 Pontiac GTO: Impulse Blue Metallic/Black/M6: lots 'o mods, 415 RWHP / 405lb/ft RWTQ!
2006 Cadillac STS-V: Light Platinum Metallic/Light Gray/A6 - Spectre CAI, Magnaflow exhaust, Speed Inc. tune, 412 RWHP / 472lb/ft RWTQ

Daily Drivers:
2015 Chrysler Town & Country Limited Platinum: Mommy's NEW RGC
2007 Chrysler Town & Country Limited: Daddy's beater affectionately called the Rolling Garbage Can or "RGC" for short
2009 Chevrolet Impala SS: LS4 V8, Victory Red
1999 Chevrolet Suburban: Sunset Gold Metallic - Daddy's winter beater and plow truck


Top
 Profile  
 
PostPosted: Wed Aug 08, 2018 12:20 pm 
Offline
Posts like an L67
Posts like an L67

Joined: Sun Aug 22, 2010 11:11 pm
Posts: 1559
Location: Ontario, Canada
Year and Trim: 2000 Bonniville SSEi L67
hi, if the upper rad hose was original, it will swell with age and the spring clamp may cut into the hose - happened to my 2000.

yes, you cant really trust the gauge as above - if you get a scantool and pull the engine control/coolant temp, it pulls the reading from the PCM and will be accurate.

first rule out the funky gauge, then you can diagnose with confidence instead of blind assumptions.

_________________
poverty forces one to do unorthodox things

2000 SSEi
past rides:
1996 SSEi
1992 GTP
1987 Grand Am


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Cooling Fans won't come on

daves99bonneville

2

561

Thu Jul 28, 2016 2:06 am

daves99bonneville View the latest post

There are no new unread posts for this topic. distributer and intercooler system kit?

Alex G!

2

378

Sat Jan 07, 2012 8:17 pm

nos4blood70 View the latest post

There are no new unread posts for this topic. New guy has a problem, auto-leveling system...

jmkees1

9

1517

Fri Apr 22, 2011 11:16 pm

00Beast View the latest post

There are no new unread posts for this topic. Another new member and have problems.

mkuquvr

2

481

Wed Apr 27, 2011 5:30 pm

00Beast View the latest post

There are no new unread posts for this topic. noob with cel problems

Fat_Nick

3

515

Mon May 05, 2014 11:16 am

Fat_Nick View the latest post

 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO