It is currently Thu Jul 19, 2018 3:21 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Jan 11, 2018 3:46 pm 
Offline
SE Member
SE Member

Joined: Sun Mar 12, 2017 1:15 pm
Posts: 14
Year and Trim: 1996 Bonneville SSE
Alright guys, I have a 96 sse and it has 2 digital screens on the cluster, one seems to be a compass of sorts on the left side of the cluster and one is the screen that shows a top down view of the car and it says which doors are open and what not on the right side of the cluster. Well when you first turn the key into the on position the top down screen is on but flickers severely and after a few seconds it shuts off and never comes back on, yet everything else still works. I had a problem with this before but noting worked ever. So I put a new cluster in and it solved my problems until now. The car has been sitting for a few months because I’m in Ohio and refuse to drive it in the winter so if anyone can think of anything please let me know thanks!


Top
 Profile  
 
PostPosted: Thu Jan 11, 2018 3:52 pm 
Offline
SE Member
SE Member

Joined: Sun Mar 12, 2017 1:15 pm
Posts: 14
Year and Trim: 1996 Bonneville SSE
Sorry guys the displays name is the driver information display that is having problems.


Top
 Profile  
 
PostPosted: Wed Jan 17, 2018 9:59 am 
Offline
Retired Moderator
Retired Moderator
User avatar

Joined: Mon May 19, 2008 1:07 pm
Posts: 2465
Location: Centerville, IN
Year and Trim: 1993 SSE

Member since Nov 2003
With the cluster being new, you might have to start by re-springing the individual pins of the dash connector. Maybe add dielectric grease when you put it back together?

My car behaves the same way...i tried to take the cluster out a few weeks ago but gave up, couldn't figure out how to get it out far enough to disconnect it. Any tips?

_________________
Image

1993 SSE Since 11-12-2000
2011 Camaro 2SS
2006 Silverado 3500 4x4


Top
 Profile  
 
PostPosted: Wed Jan 17, 2018 11:39 am 
Offline
Posts like an L67
Posts like an L67

Joined: Sun Aug 22, 2010 11:11 pm
Posts: 1512
Location: Ontario, Canada
Year and Trim: 2000 Bonniville SSEi L67
yes, it seems your dic is not connected properly - check connector pins and wires

_________________
poverty forces one to do unorthodox things

2000 SSEi
past rides:
1996 SSEi
1992 GTP
1987 Grand Am


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. 93 bonneville sse supercharged dash cluster problems?

MADDEN95L

8

2962

Fri Dec 28, 2012 2:07 pm

J Wikoff View the latest post

There are no new unread posts for this topic. Digital gas meter

Redrum84

7

686

Fri May 17, 2013 1:34 am

drift7one View the latest post

There are no new unread posts for this topic. Can the Digital AC/Heat control be used in SE

MrPOPE

2

391

Wed Apr 23, 2014 11:22 pm

bobgto65 View the latest post

There are no new unread posts for this topic. dash lamps out on my 97' sse

White93Z34

1

1314

Fri Aug 01, 2008 5:53 pm

White93Z34 View the latest post

There are no new unread posts for this topic. Dash lights

Leejr57

2

996

Tue Jul 29, 2008 5:15 pm

Leejr57 View the latest post

 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO