It is currently Thu Jun 30, 2022 12:24 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Sat May 28, 2016 3:23 pm 
Offline
LE Member

Joined: Sat May 28, 2016 3:03 pm
Posts: 4
Year and Trim: 99 pontiac bonneville se
Hi,
so a couple of weeks ago the fuel pump went bad, changed it out, ran fine for 3 weeks then died and wont start again. No fuel pressure, no power to the new pump at all.
Here is what I have done do far.
1. checked all fuses
2. changed relay (even though it worked)
3. changed pump again ( just to be safe)
4. checked ground bus on drives side rocker panel, looks very good.
5. checked for power at connector with light
Not sure about the power cant seem to get any there.
You can hear the pump does not come on. I can work on mechanical issues all day long, but when it comes to wiring and electrical, I am no good at those. Just cant seem to ever figure it out.
Can not seem to find a primer connector behind battery (as was spoke of in another thread on here)
Dont know what else to do. I am at a loss. Need to figure out if I am testing for power, at the connectors, the right way. Is there an inertia switch somewhere? maybe the fuel pressure switch? RPM signal? Anyway to check those without just changing them? Any help would be greatly appreciated.


Top
 Profile  
 
PostPosted: Sat May 28, 2016 5:44 pm 
Offline
SLE Member
SLE Member

Joined: Fri Apr 20, 2012 8:19 am
Posts: 57
Year and Trim: 2002 sle
When checking for power at the fuel pump connector, you must do so as soon as ignition switch is turned on on as it only will have power for 2 seconds. If so, you have a bad fuel pump. I am guessing that you installed a after market pump. Myself, I prefer original equipment. If you find that it is getting power during the 2 second prime, I would return your fuel pump and instead get a Delphi pump.


Top
 Profile  
 
PostPosted: Sat May 28, 2016 6:02 pm 
Offline
LE Member

Joined: Sat May 28, 2016 3:03 pm
Posts: 4
Year and Trim: 99 pontiac bonneville se
No. I bought a Delphi.(It is a new pump I have put in) I knew it only showed power for 2 secs. I had a helper turn on the ignition while i tested, I am getting no power at all at the pump. (providing I am checking the right wires) Need a diagram that shows what is what.
If any one can show where the grounds are, that would be helpful. Cant find a diagram for them.
thank you for responding.


Top
 Profile  
 
PostPosted: Sat May 28, 2016 6:54 pm 
Offline
SLE Member
SLE Member

Joined: Fri Apr 20, 2012 8:19 am
Posts: 57
Year and Trim: 2002 sle
Are you checking the gray and black wires?


Top
 Profile  
 
PostPosted: Sun May 29, 2016 7:34 am 
Offline
LE Member

Joined: Sat May 28, 2016 3:03 pm
Posts: 4
Year and Trim: 99 pontiac bonneville se
yes, grey and black, those are the wires I have checked. i get nothing on a test light.


Top
 Profile  
 
PostPosted: Sun May 29, 2016 8:59 am 
Offline
Posts like a Northstar
Posts like a Northstar

Joined: Sun Aug 22, 2010 11:11 pm
Posts: 1813
Location: Ontario, Canada
Year and Trim: 2000 Bonniville SSEi L67
THis help-

_________________
poverty forces one to do unorthodox things

2000 SSEi
past rides:
1996 SSEi
1992 GTP
1987 Grand Am


Top
 Profile  
 
PostPosted: Sun May 29, 2016 9:01 am 
Offline
Posts like a Northstar
Posts like a Northstar

Joined: Sun Aug 22, 2010 11:11 pm
Posts: 1813
Location: Ontario, Canada
Year and Trim: 2000 Bonniville SSEi L67
THis help-Image

_________________
poverty forces one to do unorthodox things

2000 SSEi
past rides:
1996 SSEi
1992 GTP
1987 Grand Am


Top
 Profile  
 
PostPosted: Sun May 29, 2016 12:07 pm 
Offline
SLE Member
SLE Member

Joined: Fri Apr 20, 2012 8:19 am
Posts: 57
Year and Trim: 2002 sle
Now you need to determine if you are losing power or ground at the pump. With your test light, from a power source, check the black wire at the pump to make sure your ground is good. If so, using the test light from a good ground, check the gray wire for power.


Top
 Profile  
 
PostPosted: Sun May 29, 2016 12:47 pm 
Offline
LE Member

Joined: Sat May 28, 2016 3:03 pm
Posts: 4
Year and Trim: 99 pontiac bonneville se
yes helps alot, will check as you suggested. thank you. will post what I find out.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Attachment(s) Fuel pump pigtail

Lunyty1

4

1872

Sun Jul 31, 2016 8:50 pm

dougtoth View the latest post

There are no new unread posts for this topic. Fuel Pump Noise

John

6

3760

Thu Jul 17, 2008 6:54 pm

crash93ssei View the latest post

There are no new unread posts for this topic. Fuel pump trouble

gsonor

3

3141

Fri Jun 13, 2008 4:31 pm

tpulliam79 View the latest post

There are no new unread posts for this topic. fuel injector harness power distribution

chris c

10

5757

Sun Jul 11, 2010 12:03 pm

chris c View the latest post

There are no new unread posts for this topic. 1999 BONNEVILLE INJECTORS NOT GETTING ANY POWER TO THEM

shundaf1

6

1380

Thu Apr 19, 2012 9:56 pm

Bing View the latest post

 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO