It is currently Wed Apr 08, 2020 1:16 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Feb 19, 2020 7:55 am 
Offline
LE Member

Joined: Thu May 23, 2019 11:08 am
Posts: 2
Year and Trim: 2002 Bonneville SE
2002 Pontiac Bonneville SE. I was about to head to work, when I started the car, it sounded terrible. Bad missing, and some backfiring sounds at the valve cover area.

I recently changed plugs and wires, they were looking pretty rough. Replaced with AC Delco professional plugs, and Duralast Gold wires. It ran fine for a few days. In fact, it seemed to run better than it had in the year I've owned it.

Anyways, after the misfires, I checked the codes and got the P0304, misfire cylinder 4. I checked the plug, it looked good, it did have a bit or dry black on it, possibly from the misfires. I changed the plugs around. Same problem. Changed plug wires around, changed coils around, changed fuel injectors around. No change at all, still the same code for the same cylinder. Sounds the same as well. I do know that the coil was sparking, although I'm not sure how much it is.

I've changed both the water pump, and battery in the past couple of months, just due to different reasons. Ran fine afterwards. This just started suddenly a few days ago. I am at a loss as for what to do. I only own this one car, and I need to get it fixed to make it back and forth to work. My entire livelihood rests on being able to figure it out. Any suggestions on what I should do next? I appreciate it in advance for your assistance.


Top
 Profile  
 
PostPosted: Wed Feb 19, 2020 5:14 pm 
Offline
SE Member
SE Member

Joined: Fri Feb 07, 2020 5:48 pm
Posts: 12
Year and Trim: 2005 Pontiac Bonneville SLE
Sorry you're having trouble, I know the feeling of having to greatly rely on having one car. Sounds like you started with the right things to check and switch around to isolate it to cylinder #4. I dont think you could have accidentally put the wrong wire on the wrong plug if it ran fine after changing plugs ??. The next things I would check is the ICM (ignition control module) that is under the coil packs..could have gone bad. Could also be a malfunctioning crankshaft position sensor. Do you have good fuel pressure ?


Top
 Profile  
 
PostPosted: Fri Feb 21, 2020 9:34 pm 
Offline
LE Member

Joined: Thu May 23, 2019 11:08 am
Posts: 2
Year and Trim: 2002 Bonneville SE
I triple checked the wires. I am unsure about fuel pressure. I believe it is okay, as all other cylinders work fine. I suppose it could be an icm. I have no way to the junkyard to get one yet though.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Misfire p0304 with some weird symptoms!

ollie2012

4

1629

Sat Dec 08, 2012 3:59 pm

ollie2012 View the latest post

There are no new unread posts for this topic. cylinder 4 misfire

Bonneville'n

0

1021

Sun May 26, 2013 4:56 pm

Bonneville'n View the latest post

There are no new unread posts for this topic. cylinder 6 misfire.

fallenangel

5

1568

Sun Mar 02, 2014 3:28 pm

fallenangel View the latest post

There are no new unread posts for this topic. cylinder 6 misfire

xrob

0

1891

Mon Oct 08, 2012 12:55 am

xrob View the latest post

There are no new unread posts for this topic. cylinder 5 misfire

[ Go to pageGo to page: 1, 2 ]

macksdaddy77

22

2383

Tue Mar 25, 2014 7:49 pm

quicksilver View the latest post

 


Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO