It is currently Sat Apr 04, 2020 9:53 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: grand prix problem SORRY
PostPosted: Mon Jan 06, 2020 1:08 am 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
Sorry for off topic but the rest of this site seems to be dead these days and I am desperate for anything that may help.

I'm looking for a little brain picking on my sons car. This thing is driving me nuts. 2004 Grand Prix. starts fine idles fine. Put it in gear and try to drive away and it will die. If you stomp it to the floor it will take off like a streak of *shoot* and pull hard until you let off the gas then it will die again. If you are sitting in park and stomp it to the floor it will rev up and bounce off the rev limiter all day long. Let off the gas and it may or may not idle. if you very very slowly rev it up it will go all the way to the floor and bounce off the rev limiter. If you just rev it up normally it will get to a certain point and just die every time. I have no CEL and no codes to work with. I have good fuel pressure. I have replaced the throttle body, gas pedal, and just because it was 7 years old I tossed in a new battery. I am grasping at straws here. The car isnt really worth taking to GM dealer to diagnose but it needs to get him through the winter before he can aford a new car. I am open to any ideas you guys may have.


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 2:18 am 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Wed May 21, 2008 11:47 pm
Posts: 6144
Location: Philly
Year and Trim: 95 SLE
Did you try running it with the MAF unplugged?

_________________
Image
95 SLE... a keeper. 241k miles. Low and Slow.
97 BMW 528i
98 Infiniti vq35'd i30: 13.3@104mph, 30MPG Hwy (RIP)
02 Jag X-type
03 BMW M5
07 Infiniti G35s 6MT
07 Ducati Monster S2R 800 with DS1000 swap
05 Suzuki DRZ400S
83 Yamaha IT175K
72 Yamaha DS7: '74 RD250 swap, JL chambers

Info on dropping a 92-99: Here.


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 2:45 am 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
No I didnt. The car is sitting in his freinds driveway out in the cold and wind 10 miles from home and that thought crossed my mind on my way home tonight but I was froze and almost home so I figured I would try that tomorrow night


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 8:22 pm 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
Well I stopped on my way home tonight and unplugged the MAF sensor. It started right up and would idle, but as soon as I touched the gas pedal it died no matter how I tried. I hate problems like this. They get expensive fast


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 9:38 pm 
Offline
Posts like an LG3
Posts like an LG3

Joined: Thu Mar 31, 2011 8:57 pm
Posts: 333
Location: MUSKEGO,WISCONSIN
Year and Trim: 2005SLE CRIMSON
2005SLE WHITE
1975 MONTE CARLO
On my son's 2000 Bonneville SLE he had a similar problem.
It turned out to be the CPS (crankshaft position sensor).
The weird thing is that the SES light never went on and there were no codes in the computer.
The other thing is that it might be the ICM (ignition control module).
You might want to look at these 2 possibilities.


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 10:41 pm 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
This car is drive by wire but at this point I am open to anything. Guess a crank sensor is only 10 bux on amazon wont be out much if it dont work


Top
 Profile  
 
PostPosted: Mon Jan 06, 2020 11:35 pm 
Offline
Posts like an LN3
Posts like an LN3

Joined: Mon May 26, 2008 10:28 am
Posts: 459
Year and Trim: 1996 Regal Custom
Crankshaft position sensor is a pain to replace only use GM 10456161 or ACDelco 213151.


Top
 Profile  
 
PostPosted: Tue Jan 07, 2020 12:51 am 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
I have all the tools and a hoist so it should only take a few minutes. We are going to go get it tomorrow night and take it to the shop since it is getting to be a guessing game. I'm just gonna have to bite the bullet and get my duelly out of storage and unload the car trailer and haul it.


Top
 Profile  
 
PostPosted: Tue Jan 07, 2020 10:20 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:30 pm
Posts: 8770
Location: Grand Rapids, Michigan
Year and Trim: 2014 Cadillac XTS Vsport.
May also want to check for a plugged cat.

_________________
*Gone, but not forgotten* - Black 2000 SSEi, HIR Headlights, Angel Eyes fogs, 3rd brake light overlay, hi-flo cat, 180 degree thermostat, HS 1.9 rockers, LSx yellow springs, Intense FWI, PCM, shift kit, push rods, and 3.4 Pulley. ZZP Power Log.


Top
 Profile  
 
PostPosted: Fri Jan 10, 2020 12:07 am 
Offline
SLE Member
SLE Member

Joined: Thu Sep 10, 2015 9:02 pm
Posts: 62
Year and Trim: 2000 SE. 2000 SSEi, 2001 SSEi, 2002 SLE
Thought I would check back. Problem solved. I finally got it hauled to the shop and put the crank sensor in tonight. Well that didnt solve the problem either. Well now I have it in a heated shop with access to WIFI for my scanner so I hook it up and download the cars specs and start checking crap. Still no check engine light at this point either. I start looking at all the parameters and happen to notice that when I would stomp on the gas there would be no change in MAP sensor readings. Well this seems a bit fishy so I jump out and unplug the MAP sensor and it instantly solved the problem. I went out of popped one out of my Bonneville parts car and plugged it in and we are back in business. I have never seen a MAP sensor cause this type of issue. Im just glad it didnt cost any more than it did. I hate breaking out the parts cannon. Well thanks for all the input. Its nice to know there are people out there willing to help.


Top
 Profile  
 
PostPosted: Fri Jan 10, 2020 1:12 am 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Wed May 21, 2008 11:47 pm
Posts: 6144
Location: Philly
Year and Trim: 95 SLE
Awesome. Thanks for posting the solution.

_________________
Image
95 SLE... a keeper. 241k miles. Low and Slow.
97 BMW 528i
98 Infiniti vq35'd i30: 13.3@104mph, 30MPG Hwy (RIP)
02 Jag X-type
03 BMW M5
07 Infiniti G35s 6MT
07 Ducati Monster S2R 800 with DS1000 swap
05 Suzuki DRZ400S
83 Yamaha IT175K
72 Yamaha DS7: '74 RD250 swap, JL chambers

Info on dropping a 92-99: Here.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Grand Prix Radio

J-ROD

6

1102

Thu Dec 18, 2008 5:06 pm

harofreak00 View the latest post

There are no new unread posts for this topic. '98 Grand Prix Misfire (Cylinder 5)

yonkerse

5

1585

Tue Dec 20, 2011 2:24 pm

yonkerse View the latest post

There are no new unread posts for this topic. Grand Prix Headers on SSEI??

3800Charged

5

870

Sat Feb 09, 2013 3:11 pm

3800Charged View the latest post

There are no new unread posts for this topic. 2005 Grand Prix Trans Issue (4T65-HD)

captainmiller

4

736

Tue Jun 20, 2017 3:38 pm

nos4blood70 View the latest post

There are no new unread posts for this topic. My brotheres Grand Prix is stalling and shifting hard.

PronksBonne

4

1347

Thu Mar 01, 2012 2:09 am

PronksBonne View the latest post

 


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO