It is currently Wed Nov 20, 2019 11:30 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: 2000 running issues
PostPosted: Sun Aug 18, 2019 6:28 pm 
Offline
SLE Member
SLE Member

Joined: Wed Jan 11, 2017 6:37 am
Posts: 30
Year and Trim: 2000 SE
I have a standard 3.8 and having issues with it stumbling and not running right.
I can get it to start if I give it gas and pump a little, I had taken it to a shop and had a scan of MAS. I replaced it with a new one but no change. I know that I should be able to unhook the MAS and it should run but it doesn't, it will run given gas and started and the promptly die.
After that I plugged the MAS back in and it idled well but stumbled and sputtered under rev or under load. Previously/ at times it would buck, backfire and throw a total fit while I would try to get it started and stay running while on and off the gas pedal.

Ideas?


Top
 Profile  
 
 Post subject: Re: 2000 running issues
PostPosted: Sun Aug 18, 2019 10:09 pm 
Offline
Certified Bonneville Nut
Certified Bonneville Nut
User avatar

Joined: Mon May 10, 2010 6:11 pm
Posts: 9127
Location: Chicago, IL
Year and Trim: 2003 SLE
If you have never replaced it yet, replace the fuel pressure regulator with an ACDelco one. I would start there.

_________________
-Car Guy Carl
"Penelope" - 2003 SLE - 193k Miles
"Sydney" - 2000 Honda S2000 - 67k miles
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. idle and running issues for the 03 *still having issues*

crash93ssei

11

2050

Sun Dec 04, 2011 3:28 pm

crash93ssei View the latest post

There are no new unread posts for this topic. SSEi running issues

bnuge942

17

2671

Wed Feb 08, 2012 3:17 pm

bnuge942 View the latest post

There are no new unread posts for this topic. Numerous running issues!

spacelucky17

10

1349

Sat Apr 27, 2013 2:07 pm

spacelucky17 View the latest post

There are no new unread posts for this topic. Starting/running issues (battery replaced)

garlandchaos

3

951

Fri May 21, 2010 6:17 pm

In_da_boondocks View the latest post

There are no new unread posts for this topic. 2000 Bonneville running rough

ThatThar

11

1560

Sun May 10, 2015 1:04 pm

ThatThar View the latest post

 


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO