It is currently Tue Dec 18, 2018 6:49 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Fri Nov 30, 2018 10:35 pm 
Offline
GXP Member
GXP Member

Joined: Wed Oct 22, 2008 8:38 pm
Posts: 265
Year and Trim: 2002 Buick LeSabre
Hi guys,
Question on an issue that happens when driving and holding the pedal at about 1800 rpms: when I release the pedal the acceleration hangs on at 1800 then drops after 3 or 4 seconds. Almost like the cruise control turning on. Same thing happens if I'm driving @ 1800 rpm and then goose the gas pedal...it will accelerate as it should, but then hang at 2000 for 3 or 4 seconds before it drops back down to 1800. The de-acceleration does not follow the throttle with the response that it should. It never surges but it hangs and doesn't follow the throttle position to de-accelerate.(tps??)

I removed the throttle body and the MAF, then cleaned the body, valves, IAC, and TPS. It was not that dirty because I recently replaced upper manifold and clean it about 1.5yrs ago. The external return springs on the throttle valve were a little oxidized so I sprayed them with some wd40, but there is really no issue with the throttle or cables mechanically...everything snaps back to base perfect and everything shiny clean. Throttle/cruise cables look perfect. Which is the most likely suspect IAC, MAF, TPS, maybe injector, pressure regulator, or other? No codes, no rough idle, no surge or starting issues. It does have cruise control, but never use it. After reading here I'm leaning towards bad tps you guys agree?


Top
 Profile  
 
PostPosted: Sat Dec 01, 2018 10:30 am 
Offline
GXP Member
GXP Member

Joined: Wed Oct 22, 2008 8:38 pm
Posts: 265
Year and Trim: 2002 Buick LeSabre
After checking further in neutral this morning..no noticeable hanging up so far... maybe the pressure control solenoid?? Are there any active procedures for changing the trans solenoids? I only found one linked to the gp forum so it is inactive.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Trans Issue or Ignition/Fueling Issue(s)

WhiteArrow3800

15

1549

Wed Aug 26, 2009 11:11 pm

WhiteArrow3800 View the latest post

There are no new unread posts for this topic. surging acceleration

spoiledred94

1

895

Fri Sep 21, 2012 12:40 pm

dz09x View the latest post

There are no new unread posts for this topic. Unintended Acceleration

Brudus10

18

993

Tue Sep 23, 2014 6:48 pm

1oldman View the latest post

There are no new unread posts for this topic. stutter during acceleration

beamer

8

976

Thu Feb 05, 2015 3:08 pm

beamer View the latest post

There are no new unread posts for this topic. Vibration on acceleration

skydiverbill

1

514

Fri Oct 16, 2015 10:10 am

nos4blood70 View the latest post

 


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO