It is currently Wed Nov 21, 2018 3:41 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Mon Jan 03, 2011 1:13 am 
Offline
SE Member
SE Member
User avatar

Joined: Sat Aug 08, 2009 4:27 pm
Posts: 12
Year and Trim: 2000 SLE
We are about to have our 2000 Bonneville inspected. My husband is wondering about the anti lock brake and traction control dash lights. They trac off light and anto lock light have been on constant since we bought the car and he is wondering if this is normal or if it means they are not functioning right? Any help would be greatly appreciated.

Thank you.

_________________
They say I have A.D.D but I just don't understa......Oh Look! A Kitty!!


Top
 Profile  
 
PostPosted: Mon Jan 03, 2011 2:28 am 
Offline
SLE Member
SLE Member
User avatar

Joined: Tue Nov 09, 2010 4:45 pm
Posts: 91
Year and Trim: 2008 BMW 535xi
This means that they are not functioning due to (most likely) one of the wheel speed sensors being bad.

_________________
My former mistresses...2001 Bonneville SSEi...extensive mods...2007 Acura TL 3.2
And my new girl: 2008 BMW 535xi


Top
 Profile  
 
PostPosted: Mon Jan 03, 2011 9:41 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:30 pm
Posts: 8721
Location: Grand Rapids, Michigan
Year and Trim: 2014 Cadillac XTS Vsport.
I agree. A scan with a Tech II or similar scanner will pin-point the problem.

_________________
*Gone, but not forgotten* - Black 2000 SSEi, HIR Headlights, Angel Eyes fogs, 3rd brake light overlay, hi-flo cat, 180 degree thermostat, HS 1.9 rockers, LSx yellow springs, Intense FWI, PCM, shift kit, push rods, and 3.4 Pulley. ZZP Power Log.


Top
 Profile  
 
PostPosted: Mon Jan 03, 2011 1:57 pm 
Offline
Posts like an L27
Posts like an L27

Joined: Sat Aug 14, 2010 9:54 pm
Posts: 634
Location: Lake Orion, MI
Year and Trim: 2000 SSEi
Just to add to what was written above...

The wheel speed sensor is the most common cause of what you describe. There is one attached to each of the front wheel hubs, so to replace the sensor you also replace the hub (they cannot be separated). This is really not a big deal. Dealerships will charge top dollar for this, but you can save money by buying your own hub (formal name is "wheel bearing") and having it installed at an auto repair shop. Or, if you know someone who works on cars, it is doable by a home mechanic also. It is a very common, routine procedure.

To find out if your problem is indeed speed sensor related, you can get your car's onboard diagnostic module scanned. The diagnostic module stores trouble codes that the car reports when there is a problem, and this is how you can zero in on the source. Almost every reputable mechanic will be able to do this, or you can also get it done for free at some chain parts stores (AutoZone for certain, others do this also but I'm not sure which ones).

A new hub itself can range from $60 (on eBay) to $150 (for a good one at a parts store). Dealerships will charge even more. The other cost will be labor, which will range from free to $200, depending upon who does the work. Again, dealerships charge the most for labor. Since this is a common procedure, there is no special knowledge that a dealer will have here versus any other repair shop.

If a scan reveals that your wheel speed sensor is indeed bad, replacing the affected hub should solve your problem and return the system to normal. If the source is something else, the scan will let you know that as well.

Ken_W

_________________
2000 SSEi "Gypssei" - 206k miles - Light Bronzemist Metallic - stock
1999 Grand Am GT - 168k miles - Red - stock DEAD -- transmission died
2004 Pontiac Montana Ext 2WD - 207k miles - Blue Black Metallic - stock


Top
 Profile  
 
PostPosted: Mon Jan 03, 2011 7:26 pm 
Offline
SLE Member
SLE Member
User avatar

Joined: Mon Dec 27, 2010 11:41 pm
Posts: 39
Location: Stockbridge, Georgia
Year and Trim: 2000 Bonneville SLE
Mine is same way - abs and brake light on, trac light shows off

Shop told me $800 for them to replace - not happening

but it also means no abs - which I learned to drive without, and have only actually used ABS once and I thought the car was possessed (it was a rental up in New Jersey)

_________________
Sheila-Marie

2000 Pontiac Bonneville

[IMG]http://i102.photobucket.com/albums/m94/GEMS1965/Bonnevilleinsnow2011.jpg[/IMG]


Top
 Profile  
 
PostPosted: Mon Jan 03, 2011 8:27 pm 
Offline
Posts like an LG3
Posts like an LG3
User avatar

Joined: Thu Jun 26, 2008 10:11 pm
Posts: 326
Location: O'fallon, Misery
Year and Trim: 2002 Bonneville SSEI(sold)
I've got the same issue. I took my car to one of the repair shops around here and they said it could be faulty wiring in the right rear. Checked it and it looked good. Sooo, I'm gonna order a replacement wheel hub for back there to see if that fixes it on Rock Auto. Alldatadiy.com has a pretty good procedure outline, and there is a techinfo article on the front ones.

_________________
~Ryan, 2002 bonneville ssei(sold)


Top
 Profile  
 
PostPosted: Tue Jan 04, 2011 1:45 am 
Offline
SE Member
SE Member
User avatar

Joined: Sat Aug 08, 2009 4:27 pm
Posts: 12
Year and Trim: 2000 SLE
sm in Georgia wrote:
Mine is same way - abs and brake light on, trac light shows off

Shop told me $800 for them to replace - not happening

but it also means no abs - which I learned to drive without, and have only actually used ABS once and I thought the car was possessed (it was a rental up in New Jersey)


{Husbad here}
Really if it wasn't for the inspection I wouldn't care about it. I learned to drive in a non ABS car.. Every car we've owned up to this one didn't have ABS. I actually prefer no ABS.

I'm just not sure if it will fail inspection with that light on.

_________________
They say I have A.D.D but I just don't understa......Oh Look! A Kitty!!


Top
 Profile  
 
PostPosted: Tue Jan 04, 2011 2:19 am 
Offline
Posts like an LG3
Posts like an LG3
User avatar

Joined: Thu Jun 26, 2008 10:11 pm
Posts: 326
Location: O'fallon, Misery
Year and Trim: 2002 Bonneville SSEI(sold)
i'll find out tomorrow. ;) my plates expired in august. havent been able to renew because of SES light i finally took care of and this *dang* stabilcrap/abs light being on. if it fails, at least i'll have a piece of paper saying i tried, lol. which prob wont matter to most cops.

_________________
~Ryan, 2002 bonneville ssei(sold)


Top
 Profile  
 
PostPosted: Fri Jan 07, 2011 1:02 am 
Offline
Posts like an LN3
Posts like an LN3
User avatar

Joined: Fri Dec 31, 2010 10:51 pm
Posts: 413
Location: Sloansville, New York
Year and Trim: 2000 SSEi: Black w/ 145,XXX miles
Having an abs light on would not fail your inspection, but in my case i had the light on too, but it is because one of my rear wheel hubs are shot and i need to replace it. Haven't got to it yet but that is the source of the problem, you can check this by jacking the car up and shaking the wheels in and out of the fender. If you can visibly see them move this may be your problem as well.

_________________
1995 Jeep Cherokee Country- 200,XXX miles and running strong. 4.0L paired with a 5 speed manual. 4.5" long arm lift with 32" tires and regeared to make up for power. Best of all, shes a fire engine red!

2000 Bonneville SSEi- 145,XXX miles, bonestock for the time (don't hold your breath, it might be a long while)

Typos courtesy of LG Optimus G- yes, I do most of my trolling with my phone. Don't judge me.


Top
 Profile  
 
PostPosted: Sun Jan 09, 2011 1:35 pm 
Offline
Posts like an LG3
Posts like an LG3
User avatar

Joined: Thu Jun 26, 2008 10:11 pm
Posts: 326
Location: O'fallon, Misery
Year and Trim: 2002 Bonneville SSEI(sold)
yeah, shortly before my trans went out again, they failed me not on the abs light but BOTH front hubs/bearings(and tie rod ends). thats at least something I can do, but it has to wait.

_________________
~Ryan, 2002 bonneville ssei(sold)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Brake light, Anti-Lock Brake light, Traction light on

Noah.Dreams

1

1637

Mon Jul 28, 2008 9:20 am

Archon View the latest post

There are no new unread posts for this topic. Anti-lock brake warning light on?

billberry12

6

1748

Tue Jul 29, 2008 4:03 am

billberry12 View the latest post

There are no new unread posts for this topic. 01 bonnie anti lock and brake light

will42805

2

672

Sun Nov 27, 2016 11:34 am

nos4blood70 View the latest post

There are no new unread posts for this topic. Traction Control/Anti Lock

Tight

1

1030

Fri Apr 08, 2011 9:25 am

Archon View the latest post

There are no new unread posts for this topic. 2003 SSEi anti-lock and traction control lights ON

rynmcdonald

5

1177

Sat Mar 14, 2015 1:40 am

rynmcdonald View the latest post

 


Who is online

Users browsing this forum: Google [Bot] and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO