It is currently Thu Feb 22, 2018 8:39 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jun 08, 2008 3:22 am 
Offline
Posts like a Northstar
Posts like a Northstar
User avatar

Joined: Thu May 22, 2008 8:52 pm
Posts: 1844
Location: Pacific Northwest
Year and Trim: Black 2001 Bonneville SSEi
A few weeks ago I got a SES ight and codes 640 and 670 (aka P1640 and P1670) . The code 1640 had been there mysteriously for months before the 1670 showed with no symptoms. Both of these codes reflect with quad driver module 4 and 1, respectively. Both of those quad drivers have the EGR valve in common as a device they control some part of. FYI the quad drivers an intregral part of the PCM that control and monitor various functions. My SES light came on when that 2nd code, the 1670 showed. Since the EGR valve was the only common device on the QDM's circuits I pulled it and replaced it. That didn't do it, the SES light was still on. I drove it for days and it still was on. I think it was post from here or BC that indicated the AC system so finally found a bad fuse under and in the Passenger dash and low and behold the AC fuse in there was blown. I replaced it and no more SES light! codes, both of them are gone.

I thought I'd post this as I did a lot of reseerch on this and there was a lot of questions but no complete answers

_________________
2001 Bonneville SSEi. 1598xx mi.
great car. Wrecked

ImageImage
Burnt Bonny.

Note if you pull the injectors to obserbe fuel delivery...make sure you leave the plugs in and disconnect the ign. Believe me


Top
 Profile  
 
PostPosted: Wed Nov 29, 2017 3:50 pm 
Offline
LE Member

Joined: Mon Oct 06, 2014 5:09 am
Posts: 7
Location: Rex,Ga.
Year and Trim: 95 ssei
Hello, I am getting quad module driver #1 fault on my 95 Bonneville ssei. My understanding is the following 4 components are controlled by this. Low speed fan,TCC apply, Evap cannisters purge, and boost bypass valve. My actron scanner says code 0640.. The car is showing no symptoms and runs fine. The live data from the scanner indicates the Evap purge comes on, no transmission trouble and the supercharger is working. I replaced the low speed fan relay, but am still getting the check engine light. I read somewhere the brakes may be involved? Any thoughts or ideas would be appreciated. I am coming up for emissions testing..Thanks!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Quad Driver Module 1 & 4

bonne-lass

3

542

Sat Aug 15, 2015 12:02 am

cjski View the latest post

There are no new unread posts for this topic. What is code 26, quad module A

gafitanu

7

861

Mon May 03, 2010 3:41 pm

J Wikoff View the latest post

There are no new unread posts for this topic. 1993 vin1 code 56 quad driver b fault

MattStrike

0

1440

Tue Aug 07, 2012 7:17 pm

MattStrike View the latest post

There are no new unread posts for this topic. error

swiles

1

450

Tue Apr 06, 2010 10:02 pm

willwren View the latest post

There are no new unread posts for this topic. CEL with P0135 error?

wolverine9827

4

427

Wed Jul 30, 2014 10:13 am

wolverine9827 View the latest post

 


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO