It is currently Sat Oct 25, 2014 2:12 pm

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Jun 25, 2009 12:26 am 
Offline
SLE Member
SLE Member

Joined: Wed Jun 04, 2008 12:55 am
Posts: 27
Year and Trim: 92 bonneville se
I have a 92 bonneville that won't start after runnung for a while. It just turns over and over and won't fire up there is no spark while turning over either. i am getting a 17 code and a 21 code. It should still fire up with the 17 code but the other one maybe not. i believe the 21 code is spark reference circiut is it not?? Could this either be icm or the pcm. Thanks for your interest..

Thanks, Dan


Top
 Profile  
 
PostPosted: Thu Jun 25, 2009 4:30 am 
Offline
Resident Gearhead
Resident Gearhead
User avatar

Joined: Mon May 19, 2008 10:19 pm
Posts: 5510
Location: Hillsboro, Oregon
Year and Trim: 2000 SSEi
2004 GMC 2500HD
2013 Buick Regal GS
Sounds like it is the crank position sensor. It gets the spark reference from a ring on the harmonic balance. Check the connection down by the crank pulley.

_________________
95se wrote:
Mini vans suck so bad! I dont own one but i drive the work van at my shop and you instantly drive like a idiot when your in one!


2000 SSEi "The Rubber Chicken" (L32 long block, S1x, Comp Cams 105# springs, OR rods, 3.0 Smoothflow MPS, Pacesetters 1-5/8 primaries, Zillamotorsports P&P SC, JP single roller timing set, FWI, Magnaflow cat, Interceptor scangauge, AEM wideband, Powerslot rotors, Hawk ceramic pads, solid transmission mount, HPT)
Image


Top
 Profile  
 
PostPosted: Thu Jun 25, 2009 7:15 pm 
Offline
SLE Member
SLE Member

Joined: Wed Jun 04, 2008 12:55 am
Posts: 27
Year and Trim: 92 bonneville se
myfirstbonnie wrote:
Sounds like it is the crank position sensor. It gets the spark reference from a ring on the harmonic balance. Check the connection down by the crank pulley.
O.k> i will give that a try . when i was outside last night and trying to start it while it was hot and thought to grab the air gun and put some air under the icm and blew some air on the crank sensor as well, and i don't know if was just the time when it kicked back in or not but it started right up . I'm going to start it up again and try it again on each. the crank sensor first and if that doesn't on the icm.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Related topics
 Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Wont Stay Running

redwingsfan34

3

265

Wed Nov 04, 2009 3:02 pm

bill buttermore View the latest post

There are no new unread posts for this topic. Car wont start! need help

calaeb0896

6

647

Tue Jul 15, 2008 2:17 pm

zuper8 View the latest post

There are no new unread posts for this topic. wont start

irish91983

19

1365

Wed Jul 07, 2010 2:31 pm

irish91983 View the latest post

There are no new unread posts for this topic. car wont start

amanda

2

416

Sat Jan 07, 2012 2:26 am

RPACODY View the latest post

There are no new unread posts for this topic. Bonneville wont start?

blademaster

4

988

Fri Jul 25, 2008 12:02 am

radomirthegreat View the latest post

 


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group


phpBB SEO